Google Connect - not working

Post your questions, bug reports and feature requests here
User avatar
gpb
Site Admin
Posts: 564
Joined: Mon Dec 19, 2011 1:23 am

Re: Google Connect - not working

Post by gpb »

Try this updated version (1.3.0):
https://www.gphotoshow.com/files/Google ... PlugIn.exe

Now it should work much better, the plugin starts downloading images as soon as a few are available, then it will continue to download the full list while running. If it is interrupted next time it will resume from the point where it was interrupted.
Getting the full files list will require more time but you will not notice it because it will be performed while downloading and displaying images.
Gianpaolo Bottin
gPhotoShow.com

laurin1
Posts: 30
Joined: Thu Sep 05, 2019 4:44 pm

Re: Google Connect - not working

Post by laurin1 »

Seems to be working well on my primary machine, but still not working on the secondary machine. Could the reason be that I RDP into that machine so that it is using the logon screen saver and not the console?

User avatar
gpb
Site Admin
Posts: 564
Joined: Mon Dec 19, 2011 1:23 am

Re: Google Connect - not working

Post by gpb »

Logon screen saver is always a source of troubles because is run under a very limited user account.
First of all every time you change something in gPhotoShow settings from your user account you must set it as logo screen saver. You must do it every time. This is required because as I wrote before it is started by windows under a special account, when you set it as logon screen saver gPhotoShow copies its settings under that account.
Another thing to consider is that the folders used must be accessible by all users, usually folders under c:\users are not accessible by other users.
DirectX and other COM compoonents may not be available when running as logon screen saver
Gianpaolo Bottin
gPhotoShow.com

laurin1
Posts: 30
Joined: Thu Sep 05, 2019 4:44 pm

Re: Google Connect - not working

Post by laurin1 »

I'm aware of the folder access limitations...oh, I think I know what the problem is, I made sure all users had read in the past so that it would display, but I need to give them write.

laurin1
Posts: 30
Joined: Thu Sep 05, 2019 4:44 pm

Re: Google Connect - not working

Post by laurin1 »

I was wrong. I can't get it work on my secondary machine when on the logon screen, which it is most of the time.

User avatar
gpb
Site Admin
Posts: 564
Joined: Mon Dec 19, 2011 1:23 am

Re: Google Connect - not working

Post by gpb »

Logon screen saver is problematic because it runs under a special user and all settings are stored for current user, Google plugin saves authorization token in this registry key and it is not copied by gPhotoShow when setting the logon screen saver:
HKEY_CURRENT_USER\SOFTWARE\GPGSoftware\GoogleConnPlugin

You could try to use regedit and manually copy everything to:
HKEY_USERS\S-1-5-19\SOFTWARE\GPGSoftware\GoogleConnPlugin
Gianpaolo Bottin
gPhotoShow.com

laurin1
Posts: 30
Joined: Thu Sep 05, 2019 4:44 pm

Re: Google Connect - not working

Post by laurin1 »

Ok, I'll try that.

laurin1
Posts: 30
Joined: Thu Sep 05, 2019 4:44 pm

Re: Google Connect - not working

Post by laurin1 »

It's working, except for one thing, and this is happening on both primary and secondary right now, is it's not adhering to my caching limit of 100. I don't care that it is not, but just thought that I would let you know.

User avatar
gpb
Site Admin
Posts: 564
Joined: Mon Dec 19, 2011 1:23 am

Re: Google Connect - not working

Post by gpb »

Is the plugin keeping more pictures than the limit or less ?
Gianpaolo Bottin
gPhotoShow.com

laurin1
Posts: 30
Joined: Thu Sep 05, 2019 4:44 pm

Re: Google Connect - not working

Post by laurin1 »

More. Limit is set to 100. Right now, there are 564.

Post Reply