ControlSS shows disabled after resuming from sleep

Post your questions, bug reports and feature requests here
Post Reply
paul1965
Posts: 39
Joined: Fri Dec 19, 2014 3:21 am

ControlSS shows disabled after resuming from sleep

Post by paul1965 »

I just revived a Samsung Series 7 Slate running Windows 10, and have loaded several different screensavers on it. I've also installed ControlSS to run a different screensaver each time the Slate resumes from sleep. However I've noticed that ControllSS is disabled and the screensaver never launches. If I restart the Slate, everything works as expected, so this appears to be an issues with ControlSS not working correctly after resuming from sleep. If I try to toggle its status manually, it briefly changes to enabled, then back to disabled after just a few seconds. Any suggestions on how to get it to work properly?

User avatar
gpb
Site Admin
Posts: 596
Joined: Mon Dec 19, 2011 1:23 am

Re: ControlSS shows disabled after resuming from sleep

Post by gpb »

ControlSS icon only reflects the windows screen saver status, if it displays "disabled" it means that for some reason the windows screen saver is disabled and can't be started.
I don't know why this happens after resuming from sleep, anyway ControlSS only reads the screen saver status from windows and changes its icon accordingly, it never enables/disables the screen saver by itself.
Gianpaolo Bottin
gPhotoShow.com

paul1965
Posts: 39
Joined: Fri Dec 19, 2014 3:21 am

Re: ControlSS shows disabled after resuming from sleep

Post by paul1965 »

I see, thanks. I'll trigger a manual sleep and resume and check the screensaver status afterwards.

paul1965
Posts: 39
Joined: Fri Dec 19, 2014 3:21 am

Re: ControlSS shows disabled after resuming from sleep

Post by paul1965 »

You are correct, this is an issue with Windows 10. I tested another Slate I have running 8.1 and the screensaver worked correctly after resuming from Sleep. For now I've added a scheduled task to restart the Windows 10 Slate after it's resumed from Sleep, and that should fix it for me (until I find a better solution, or roll it back to 8.1).

Post Reply